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Installation 
• Login to admin panel. 

• Go to Extensions > Installer. 

• Upload the extension file with name ending with “.ocmod.zip”. 

 

• Go to Extensions > Modification. 

• You will see new Modification Named as “Purpletree Custom Product Designer for Opencart 

3.x”.  

• Click on Refresh Button on top right.  

 

• Set User group permissions for admin. Go to System > Users > User Groups 

• Tick Mark following  in Access Permission and Modify Permission 

o extension/purpletree_product_designer 

o extension/purpletree_product_designer/clipart 

o extension/purpletree_product_designer/product_designer_fonts 

o extension/purpletree_product_designer/product_designer_products 

o extension/purpletree_product_designer/producttemplate 

• Save Changes. 



 

 

• Go to Extensions > Extensions.  

• From choose the extension type, select Modules from Dropdown. 

• Find Purpletree Custom Product Designer, install it and click on edit button. 

• From General Tab, Select Status as “Enabled”. 

• Click on get License and Enter License key for the extension. 

Usually license key is automatically sent sometime after purchase, on the email id of the extension 

purchaser. If you still haven’t received it, please open a ticket with us from 

https://helpdesk.purpletreesoftware.com. 

Or 

Click on “Get License” button. Enter your Order ID which was generated when you placed an order 

for our extension and “Email ID”. Click on Submit Button and your license key will be filled on 

License key field. 

 

 

• Setting 

https://helpdesk.purpletreesoftware.com/


 

o Use Child Products - Using this Admin can define multiple Child products for a  single 

product, or you can say multiple templates for a product, using this admin could defined 

pre-defined designs from admin panel so that Front user could just change the content 

and use the predefined design created by admin for child products. Set it to Yes for 

admin to create Child products from Main product else admin won’t be able to create 

child products. 

o Upload Help Image - Using this, Admin can upload help image for customer. It will be 

Informative Image comes on designer page. Here the admin can also change the image 

as per his choice and help the customer in other options. 

o No of Options for Book Printing – This option is to create Multiple PDF Upload Options 

for Book Printing Product. Enter Valid number here and on Save that, number of Upload 

options would be created in Admin > Catalog > Options as PDF Option 1,2,3and so on. 

o PDF Validation on Product Page –Enable it for Book Printing Product for PDF file 

validation on product page and Counting PDF pages and Price accordingly. 

o Use CMYK Color picker – Enable it to use CMYK color picker so that user can enter 

values for CMYK colors or Set to No for Normal Color Picker. 

o Watermark – Set this to Enable for Watermarked image when user design anything on 

Frontend. So that user won’t be able to Design the product here and use the product 

image somewhere else. For Admin, Design images would be without Watermark for 

printing purpose. 

o Watermark Text – If the above option is Enabled, Enter Watermark Text for the images 

for frontend after designing. Default is set to Sample. 

• Now for Development Option this has to be set only if selected theme of the store doesn’t have 

jQuery, jQueryUI or bootstrap in it.  

• No need to check these checkboxes if using Default theme as it already have jQuery and 

bootstrap.js.  

 

• Layer Options - In Layer Options Tab Enter the values which would be used when Designer 

Product is added to cart with design, so that Extra price would be added as per according to 

layers defined in here. For Example, if admin adds Min Layer to 5and MaxLayer to10 and 



 

price to be 10, then on adding layer from 5 to 10, extra price of 10 (Whatever currency is 

set) would be added as an Product option and means user has to pay $10 extra if Design 

layers for the products are more than equals to 5 and less than equals to 10. If Multiple 

Prices and layers are added in this grid, then in frontend, Maximum price would be used and 

added in cart with product. 

 

Extension supports multiple languages 
 

This extension provides full support for following languages, i.e., these languages are built in. 

Just change the languages from admin settings, and you are done. 

• French 

• German 

• Turkish 

• Russian 

• Spanish 

• Portuguese  

 

 



 

Assigning Product Canvas Layer Options 
 

• To assign Product Canvas in Admin Go to Purpletree Custom Product Designer > Settings > Layer 

Options. 

• You can set minimum layer to maximum layer of price. 

• You can add layer options zero and more than zero.  

• If you are not adding any layer options than it will go on as before.  

 

• You can add multiple layer options allowing the admin to set the price of his layer. Now the 
customer has to pay the product design according to the no of layer. It is very use full 
functionality for you. For example if admin want to set one to five layer prices is 5 dollars and six 
to ten layer price 10 dollars. Now you can do it. 

Adding Clip Art Images 
• Admin can add Clipart Images which user can add on product. These will be predefined images 

added by admin as clipart images. 

 
• To add the new Clipart image click on Plus Sign in front of Clipart and then select image and click 

edit to choose image from File Manager. 



 

 
 

• After adding all the images. Click on Save Button on top right to save the Clipart images so user 

can use them on product. 

• To Delete the Clipart Image just click on minus button in front of each image. No need to Click 

Save button. Image will immediately delete once you click on minus button. 

 

Get Custom Design of Product – 
 

• In Admin under Purpletree Custom Product Designer there is Mange Products. In there Book 

Printing and Designer products would be visible. 

• Admin can add Child Products for Designer product only and not for Book Printing Products. 

• Add the New product from top right or Edit the Product from Edit button in front of each 

product. 

• Product can add or edited from Catalog > Products Menu also. Manage products listing under 

Purpletree Custom Product Designer is forviewing the Designer products only. 

 



 

• To assign Product Canvas in Admin can also Go to Catalog > Products >Add/Edit product 

• Here you will see new tab Custom Product Designer. 

 

• Click on this tab. To assign product as Designer product. Select YES forOnline Product Design. 

• If it is Book printing Product. Set Yes for that. At a time Product can isDesigner Product or Book 

Printingproduct. 

• Then Enter Short Description, which would be visible on product page. 

Assigning Product Canvas Layer Limit 
• Enter Total layers, Max text layers, Max clipart layers and Max image layers for this product. 

• If you have set Max total Layerto 100 for all label layers.Now the customer cannot add more 

than 100 layers. Default is set to 999. 

• If you have setMax test Layersfor all labels to 10. Now the customer cannot add more than 10 

text layers. If total limit is 09 then customer cannot add text layers more than 09. Default is set 

to 99. 

• If you have setMax clipart Layers of all labels to 10. Now the customer cannot add more than 10 

clipart layers.If total limit is 09 then customer cannot add clipart layers more than 09. Default is 

set to 99. 

• If you have setMax image layers of all labels to 10. Now the customer cannot add more than 10 

image layers.If total limit is 09 then customer cannot add image layers more than 09. Default is 

set to 99. 

• If you have setMax icon Layers of all labels to 10. Now the customer cannot add more than 10 

icon layers.If total limit is 09 then customer cannot add icon layers more than 09. Default is set 

to 99. 



 

• If you have setMax shape Layers of all labels to 10. Now the customer cannot add more than 10 

shape layers.If total limit is 09 then customer cannot add shape layers more than 09. Default is 

set to 99. 

• If sum of text, clipart, image,icon,shape layer more than total layer than customer cannot add 

layers more than total layers. 

• If Max text layers, Max clipart layers, Max Icon layers, Max Shape layers and Max image layers is 

set zero than related menu will not see on product design page in frontend. 

 

 

Safe Line:  Admin can define safe line. This will appear on product design page. 

Bleed size:  Admin can use crop line. This will appear on product designer page.  

Fold Line:using this, admin can set fold line also. This will appear on customer side. Admin can set 

multiple fold line. For example, if admin want to set two fold lines in design area then admin can set fold 



 

line with coma separated like 100,100.  This would not come in Final Design but would be visible while 

designing the product. You can use this for Foldable Catalog printing type of products. 

Always on top 
If you have selected Always on Top, then the background layer will always on top when the layer is 

loaded or the layer is added. You can use this option when you PNG Image Background and want user to 

add layers below background image.  

 

Now you will click on “Create Design”. After that we will add a layer, the layer will always be adding only 

after the background image. 

 

 

Below is the example like you admin add Background PNG images in shapes then when user add any 

layer in that it will always comes in background. We have Given links to following Shapes as predefined 

images which you can use in your project without worrying about copyright. 



 

Star Shape – https://opencartdemo.purpletreesoftware.com/image/shapes/star.png 

Heart Shape – https://opencartdemo.purpletreesoftware.com/image/shapes/heart.png 

Hexagon Shape – https://opencartdemo.purpletreesoftware.com/image/shapes/hexagon.png 

Circle Shape – https://opencartdemo.purpletreesoftware.com/image/shapes/circle.png 

Triangle Shape – https://opencartdemo.purpletreesoftware.com/image/shapes/triangle.png 

Diamond Shape – https://opencartdemo.purpletreesoftware.com/image/shapes/diamond.png 

Oval Shape - https://opencartdemo.purpletreesoftware.com/image/shapes/oval.png 

 

 
 

Assigning Product Canvas 
 

• You can add Designs below by click on Add Button. 

•  For Product if you want to use Image, SetYes in Use Image Dropdown, else set No and set 

Height andWidth for it. 



 

• If use image is set to yes, then you can Define Image for that and Click on Create design to 

Define Design area for it. In this case Safe Line,Bleed Line and Fold Linecannot be used.Always 

on Top can be used in this case. 

• If useimage is set to no, then define height and widthfor the designarea, Createdesign button 

would be disabled in this case and you can define Safeline, bleed line and Fold line for the 

same.Always on Top cannot be used in this case. 

• Enter Labeland Sort Order for each image. 

• Enter DPI for the Image. 

• Now to Create Canvas area has to be selected by admin in which user and add there design. 

• Now select the editable area within the image by using Mouse Drag. 

• Drag the box anywhere on screen to define area. 

• Resize the Box From Left, Right or Bottom Right Corner. 

• Close the Popup. 

• Select Canvas Area for all images. 

• All Setting will be saved on Product Save. 

• So Click on Product Save button on top right . 

 

• Define Price and Quantity for Product accordingly in Price and Quantity tab. If not Set Product 

price and Quantity from Data Tab would be used as default. 



 

 

Upload your Design 
To create Product for getting your own design, just create Option with Name “Upload Your Design”. This 

string must be same. 

 

You have to write below strings for other languages as selected for Opencart website 

 

French-Téléchargezvotre conception 

Portuguese-Carregueseuprojeto 

Spanish-Subetudiseño 

Turkish-TasarımınızıYükleyin 

German-Laden SieIhr Design hoch 

Russian- Загрузитесвойдизайн 



 

When you will write this string, only then it will appear at frontend at Upload your design option in 

desired language. 

 

• Add it in product and make it notrequired. 

 

Child Products 
Admin can add child product also.  

Child products are useful when there is a general product design, and then there are different sub-

designs or formats which a user can select and design. For example: Visiting Cards. 

Adding Child Product 

Go to: Purpletree Custom product designer >Manage Products >Add Child Product for designer 

Product. 

When, you will click on product detail button. You will see following page. 

• Enter Design Name, Sample Image for listing and All Max fields. 

• You can add Designs below by click on Add Button. 

•  For Product if you want to use Image, Set Yes in Use Image Dropdown, else set No and set 

Height and Width for it. 

• If use image is set to yes, then you can Define Image for that and Click on Create design to 

define the Template design. 

• If use image is set to no, then define height and width for the design area and click Create 

design to define the Template design for that height and width. 



 

 

Safe Line:  Admin can define safe line. This will appear on product design page. 

Bleed size:  Admin can use crop line. This will appear on product designer page.  

Fold Line: Using this, admin can set fold line also. This will appear on customer side. Admin can set 

multiple fold line. For example, if admin want to set two-fold lines in design area then admin can set fold 

line with coma separated like 100,100.  This would not come in Final Design but would be visible while 

designing the product. You can use this for Foldable Catalog printing type of products. 



 

Always on top: If you have selected Always on Top, then the background layer will always on top when 

the layer is loaded or the layer is added as explained in previous section. 

According to this page we will set all value for canvas area.  

• Admin will have to fill all canvas fields like Label, image dpi, safe line, bleed size, crop line, fold 

line and sort order. Default values are already set for all fields. After that we will create canvas. 

 

• Admin can see safe line and bleed size here. Admin can add text, clipart, icons, shapes, and 

images from here in canvas.  

• Admin can do reset canvas and view canvas, undo redo and zoom also.  

• We can set toggle flip, horizontal align, vertical align, move left, move right, move top, move 

bottom , delete and copy also on canvas layers.  

• Admin can add text in canvas and set properties of text. 

• First, we will click on “add text” after that we will see a popup of edit text. Admin can decorate 

text, styling and set text position here.  



 

 

• Admin can set all properties of text from here. 

 

 

 

 

 

 

Add Clipart: 



 

Admin can choose clipart from popup and set in canvas.  

 

Add icons:  

Admin can set icon from popup. We will have to double click on selected icon after that icon will set in 

canvas.  We can change color of icons also.  Icons can also be searched from name. 

 

Add shapes:  

Admin can add shapes here. We can add circle, rectangle and line. Admin can set color of shapes also.  



 

 

Add Image:  

Admin can add image in canvas from here. 

 

 

Frontend Product Designer Page 
• On Front end user will go to Product page. There will be options for custom designer. 

• Select Options from Product Page, Select Quantity and Price for template Product which is 

added in admin. 

• Click on Browse Designs button. 



 

 

 

• Here comes the list of templates Select the Template and Click on Start Designing Button. 



 

 

 

• Design the Template which is added by admin. 

Design for Product 
o Add text layer– In Here there are lot of functionalities. Add text in Product image for 

custom design. 

▪ Add Text – Enter Text the text area. 

▪ Choose a Font – Choose Font from Popup. 

▪ Text Color–Select Color from Color Picker for Text. 

▪ Font Size – Select Font Size from Dropdown. 

▪ Background Color (Reset) – Select Background Color from Color Picker from 

text. Click on Reset button to reset the background color to transparent as 

default. 

▪ Shadow – Select Shadow Value from design in Right, Bottom and Blur value and 

Select Shadow Color. 

▪ Text Style – Select Bold, Italic and Underline Style from her. 

▪ Text Align – Text will be aligned to left, Center or Right from here. 

▪ Horizontal scale – Enter Width in input box. 

▪ Vertical scale – Enter Height in input box. 

▪ Rotation (in Degree) – Rotate the Text to any value like you can rotate it to 90 

Degree. 

▪ Line Height – Enter line height in text Area. 



 

▪ Outline Width – Enter Width for outline Width. 

▪ Outline Color – Select Color from Color Picker. 

 

Canvas Tools 
o Toggle Flip– to Toggle the selected layer, the layer will be toggle to opposite. 

o Horizontal Align – To align the layer horizontally within canvas area. 

o Vertical Align – To align the layer vertically within canvas area. 

o Move Left – To move the selected layer left from their original position. 

o Move Right – To move the selected layer left from their original position. 

o Move Up – To move the selected layer upward from their original position. 

o Move Down – To move the selected layer downward from their original position. 

o Delete – This will delete the Selected Layer from Canvas area. 

o Reset – This will reset the Canvas area to blank as it was original. It will ask for 

confirmation, Select Yes to Reset the Design. 

o Copy – To Duplicate the Selected Layer. 

o View – To view the Designer image in Popup. 

o Download PDF – User can download the PDF of the design created. PDF design would 

be watermarked. Only Logged in user would be able to download the PDF. If customer 

not logged in, page will be redirected to OpenCart login page and on successful Login, it 

will come back to this same designer page and Downloading PDF would start. 



 

o Send Design PDF – This will send the PDF design to customer Email id. All images in PDF 

would be watermarked. Here also Logged in customer would be able to send PDF to 

their registered email id of their account. If not logged in page will redirect to login page 

and would come back to this page and PDF would be sent to customer email id on 

successful Login. 

o Save for later – Click on Save button to save the design for later and load the design and 

continue designing, in here also customer login is required, else page would be 

redirected to login page and would come back to this page on successful login. 

•  

o Bleed line- We will show the “bleed line” with black line. 

o Crop line- We will show the “bleed line” with red line. 

o Fold line -We will show the “bleed line” with black line. 

o Safe line-We will show the “bleed line” with green line. 

 

 

 

• User can add as much Text layer as you have set Text layers on product in the admin side. 

• If you have set max text layers zero on product in the admin side than “Add Text” will be hide. 

• If you have set max clipart layers zero on product in the admin side than “Add Clipart” will be 

hide. 

• If you have set max image layers zero on product in the admin side than “Upload Image” will be 

hide. 

• If you have set” Max image layer” set zero then “Upload image” will be hide. 

• If you have set layer option price in setting, then you will see that layer price will add in total 

price. Extra price will show on cart. For example, product price is 100 and with layer price will be 

130.50. In this following cart page, you will see Layer price 30.50. 



 

 

 

 

• Add Clipart – User can add art images in the Product image, these images are predefined by 

admin. Select Image from Popup and put it on Canvas Area. 

 

 
 

• Add icons -Admin can set icon from popup. We will have to double click on selected icon after 

that icon will set in canvas.  We can change color of icons also.  Icons can also be searched from 

name. 

• Add shapes -Admin can add shapes here. We can add circle, rectangle and line. Admin can set 

color of shapes also.  

• Upload Image – Upload the image from your computer to put it on Product Image. 



 

• Layers – There is a list of Layers added on current image will come here. You can delete or 

change position of Layer by Mouse Drag from here. Topmost layer that is visible on product 

image is the Last Layer on the list with descending order. 

o Layers Order is in descending Order. 

o Selected Layer is highlighted as green as in below screenshot. 

o Layers Position can be changed by dragging the layer. 

o Delete the layer on click of delete button in front of each Layer. 

 

 

Custom Design 

 

 

 

In custom design admin don’t have to define layers just click on Get Custom Design 



 

 

• Here customer can define Layers. 

Always on top:  If you have selected Always on Top in admin side, then the background layer will always 

on top when the layer is loaded or the layer is added. 

 

 

Upload Your Design 

• To upload your design just click on Upload Your Design, once file is uploaded button 

would be renamed to Add to Cart with Upload Design. Click on it to Add to Cart with 

Upload Design to add the product in cart with this image only and checkout. If Image is 

uploaded, then other 2 buttons would be disabled. 

 



 

Add to Cart 
 

• To place the order for designer image, Click on Add to cart from designer page. 

• On Add to cart, user can check the Designer image is visible in Mini cart and on Cart page. If 

product is successfully added to cart. 

 

• Place the order and Image will be passed to Order and after that admin and customer both can 

check the Designer image from Order Detail page. 

 

Buy Design only 
Using this button user can buy the design which can be seen by customer on their orders. All Design 

Images along with PDF which admin could see in order will also be visible in Customer Side Order detail 

page if it is enabled and customer buys the product from this button instead of Add to cart. 

• To Enable “Buy Design only” Go to  admin >Purpletree custom product designer > settings. 



 

 

• After enable “Buy Design Only button”, after that you will go to product design page. And click 

on the ‘get custom design’ or ‘Browse design’ button.   

 

• You will get the “Buy Design only” button on the product designer page.  

 



 

 

• Order detail page all design images and PDF can be downloaded by user. 

 

  



 

Order Detail Pages 
 

 
Admin can download and preview images in jpg and png format. Admin can download all images 

in a pdf also.  

 

Save for Later 

• From Design Page Click on save button on top. It will be saving only if logged-in. 

• Login to Your account. Go to account page and click on Saved Designs. 

• Customer can view the design or delete the design. 

• Customer can load the design from View button and continue designing. 



 

 

  



 

Support 
 

If you face any issue, please raise a ticket on https://helpdesk.purpletreesoftware.com  with  

• Your order id 

• Opencart admin logins  

• cPanel or FTP credentials  

• Detailed issue description 

• Screenshots 
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